Export OpenOffice de cette article Exporter la page au format Open Document

Linux On Laptops

Installation Lenovo3000 V200

Récaputilatif

Installation de la Gutsy

Seule la version Gutsy d'Ubuntu a bien voulu s'installer sur cette machine très récente.

Le repartitionnement du disque de 120Go s'est fait à l'aide de gparted http://gparted-livecd.tuxfamily.org/. Partition magic (8.05) a refusé de reconnaitre les partitions existantes. Les outils libres seraient ils plus puissants que les payants ;-) ?

Ras concernant l'installation, cela devient trop facile…

Wifi

Si de noubreux soucis existaient avec la version béta de la Gutsy, les mises à jour ont corrigé de nombreux problèmes.

L'applet network-manager est des plus puissant.

nm-applet : network manager applet

retrouvez tout cela ici : http://www.crium.univ-metz.fr/reseau/wifi/acces/NetworkManager/

PB son

Pb acpi pas de son si démarage avec secteur

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/108392

solution : démarrage sur batterie puis branchement secteur

PB le branchement du casque audio ne supprime pas les enceintes

Des soluces qui ne marchent pas :

https://wiki.ubuntu.com/LaptopTestingTeam/Lenovo3000N100_0768?highlight=%28lenovo%29
A work-around consisted of unchecking the “External Amplifier” box in
the sound panel applet, but it caused severe sound degradation.
Moreover, it is not the right way to mute the speakers, it just disable
an amplifier which causes the loss of quality.

In order to get sound to work properly a manual compile of a patched
ALSA is needed (instructions below). alsa-lib and alsa-utils version
1.0.15rc1 will be compiled and installed, alsa-driver as of september
8th of 2007 (HG snapshot) will be patched and then built and installed.
https://bugs.edge.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/94566
Now building/installing alsa 1.0.15rc3 with a small fix (the patch
consists in a boolean negation, see
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2581) fully
corrects the speaker issue on Lenovo 3000 N100, but the patch brakes on
other laptops (like Samsung X60)... So I think some more work is needed
to distinguish the two "sort" of laptops (those like Lenovo's 3000 N100
and the others). That's why it may be hard to get it fixed in gutsy.

le bug n'est pas encore résolu, malgré l'installation de la version 1.0.15 d'alsa!!!

Bio-authentification

Pilote fingerprint pas testé

http://www.ag-networking.com/

Icône de bureau

source : http://ubuntu7.canalblog.com/archives/2007/10/17/6570700.html

Par défaut sous Gutsy, le bureau n'est plus afficher, il faut pour cela installer un utilitaire gtweakUI.

sudo apt-get install gtweakUI

ensuite dans le menu “Système” de Gnome, choisir “Préférences” puis “gtweakUI - Nautilus” Sélectionner les icônes à afficher sur le bureau puis valider en cliquant sur le bouton “Fermer”.

Bureau 3D

trouvé ici http://forum.ubuntu-fr.org/viewtopic.php?pid=1242482#p1242482

c'est normal que ca ne marche pas. Ce n'est pas un mauvais driver mais une limitation voulu par le developer de compiz.Les carte intel x3100 sont en liste noire de compiz. L'activation de compiz cause une incompatibilié avec xv pour la lecture de video. Pour lancer tout de meme compiz, il faut commenter certaines ligne ( celle qui donne la liste noire) au debut de /usr/bin/compiz ATTENTION

En faisant ca, compiz va marcher, mais totem ne lira plus aucune video. IL faudra utiliser Mplayer( ou autre …) et le configurer pour ne pas utiliser xv mais x11 par exemple pour lire des videos.

Ps le dirver est bien le experimental […] et surtout pas le i810.

il faut commenter des lignes dans la blacklist de compiz (celle des chips 965)

# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T="   1002:5954 1002:5854 1002:5955" # ati rs480
T="$T 1002:4153" # ATI Rv350
#T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12"  # intel 965
#T="$T 8086:2972" # i965 (x3000)
T="$T 1002:3152 1002:3150 1002:5462 1002:5653 " # ati X300 X600,X600 X700
BLACKLIST_PCIIDS="$T"
unset T

et hop, ça le bureau tourne dans tous les sens… pour l'instant c'est plutôt stable…

Les fenêtres 3D avec ''compizfusion''

Tout est ici :

http://forum.compiz-fusion.org/showthread.php?t=5303&highlight=3d+windows

Suivre la documentation et lancer compiz dans une console. Dans mon cas l'applet bureau 3D n'arrive pas à lancer les fenêtres 3D.

Dans les grandes lignes, il faut télécharger des nouveaux plugins, les compiler et les installer. Avec l'utilisateur non root faire : Télécharger le plugins à l'adresse http://gitweb.opencompositing.org/?p=fusion/plugins/3d;a=snapshot;h=db3c51d6c5c0df268fc1ec29a4264ef3d21dbbb3

sudo apt-get install compiz-bcop compiz-dev build-essential libxcomposite-dev libpng12-dev libsm-dev libxrandr-dev libxdamage-dev libxinerama-dev emerald libstartup-notification0-dev libgconf2-dev librsvg2-dev libdbus-1-dev libdbus-glib-1-dev libgnome-desktop-dev x11proto-scrnsaver-dev libxss-dev libxslt1-dev libtool
mkdir -p  ~/compiz/
tar -xf 3d.tar.gz -C ~/compiz/
cd ~/compiz/3d
make clean && make && make install

ensuite faite la configuration du module à l'aide de Système→Préférences→Advanced Desktop Effects Settings comme suit :

Configuration de 3D windows

Configuration de 3D windows

et voici le résultat en lançant compiz depuis un terminal :

Le bureau 3D compizfusion

Les JRES en 3D ;-)

l'autonomie est ridicule ~ 1h20!!!! du coup achat de la batterie 6 cellules ici http://www5.pc.ibm.com/fr/products.nsf/ … eb_express

Autonomie ridicule

L'autonomie est ridicule ~ 1h20!!!! du coup achat de la batterie 6 cellules ici Page accessoires batterie

L'autonomie passe alors à plus de 3h, elle est donnée pour 5 heures sur le site !!!

Avec le changement de batterie, j'ai de nouveau des soucis avec le wifi et le son! retour sur l'astuuce “démarrage en mode batterie puis branchement des périphs”

Vue du portable avec la batterie 6 cellules

Mise à jour à Hardy Heron : Problème Wifi avec Eduroam

La version 8.04 d'ubuntu vient de sortir, c'est l'occasion de mettre à jour notre portable lenovo. Tout est dispo ici http://www.ubuntu-fr.org/telechargement.

La mise à jour à été faite en mode graphique à l'aide du gestionnaire de mise à jour. Tout s'est bien passé. Le redémarrage se fait sans emcombres et je retrouve mon bureau Gnome.

On notera que le problème du branchement du casque audio qui ne supprime pas les enceintes a disparu. Merci le Héron.

Le son est présent et le bureau 3D fonctionne sans réglage particulier. Un clic droit sur le bureau puis changer l'arrière plan nous donne accès à la configuration des effets 3D.

Allez on teste le wifi maintenant puisque notre carte une Intel Corporation PRO/Wireless 4965 et le pilote de cette carte est maintenant intégré au noyau 2.6.24 de notre Heron préféré cf http://www.intellinuxwireless.org/?p=iwlwifi pour plus d'information.

Un lspci -vvv nous le confirme

06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
    Subsystem: Intel Corporation Lenovo ThinkPad T61

Je mets en route le wifi par le bouton adéquat du portable et là plusieurs surprises m'attendent :

  • la connexion sur des réseaux non sécurisés fonctionne
  • la connexion sur des réseaux sécurisés WPA fonctionne
  • la connexion sur des réseaux sécurisés WPA2 ou WPA Entreprise ne fonctionne pas (Eduroam par exemple)

Après quelques recherches, il semble que ce bug soit connu, mais pour l'instant le pb reste entier.

Sur le forum du site intellinuxwireless, il semble qu'il faille utiliser les derniers drivers wifi compat-wireless (message du 02/05/2008) http://wireless.kernel.org/en/users/Download#DownloadlatestLinuxwirelessdrivers

cf http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1522. Le noyau 2.2.25 ne semble pas affecté par ces soucis.

J'ai opté pour une autre solution, peut être moins jolie puiqu'elle utilise le pilote windows du composant wifi, mais qui s'est révélée très fonctionnelle pour moi.

Ndiswrapper

Dans un premier temps on va télécharger le pilote windows de notre carte Intel PRO/Wireless 4965. Ils se trouvent ici.

La paquet fait plus de 30 Mo et nous n'avons besoin que d'un fichier .sys et .INF !!! tant pis. Les fichiers NETw4k32.INF et NETw4k32.sys se trouvent dans le répertoire SWTOOLS\DRIVERS\WLLANINT\XP\Drivers lorsque vous avez décompressé l'archive http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-68011

On téléporte ces deux fichiers sur notre hardy heron. Puis on installe ndiswrapper.

sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

Voilà on est paré pour installer notre pilote sous linux. Pour la suite je me suis largement inspiré de l'article du Linux Pratique 47.

On désinstalle le module iwl4965 chargé par défaut :

# rmmod iwl4965

un petit lsmod permet de vérifier que le driver a bien été désinstaller. On commence par installer le pilote :

# ndiswrapper -i /chemin_vers_le_pilote/NETw4k32.INF

On vérifie l'installation du pilote par :

# ndiswrapper -l
netw4x32 : driver installed
    device (8086:4230) present (alternate driver: iwl4965)
#

On sauve ensuite la configuration dans le fichier /etc/modprobe.d/ndiswrapper

# ndiswrapper -m

Ensuite on charge le module par la commande suivante :

modprobe ndiswrapper

A partir d'ici tout devrait être fonctionnel au niveau du wifi.

Il reste cependant un problème, au prochain redémarrage c'est à nouveau le pilote iwl4965 qui sera chargé au démarrage. Il faut alors le 'blacklister'.

echo 'blacklist iwl4965' | sudo tee -a /etc/modprobe.d/blacklist

Ensuite on impose le chargement de ndiswrapper au démarrage

echo 'ndiswrapper' | sudo tee -a /etc/modules

Voilà, encore un petit redémarrage pour vérifier que tout fonctionne.

Encore des soucis

Avec le pilote ndiswrapper, je ne peux plus me connecter à la maison via mon routeur Wifi en mode WPA2 Personal avec cryptage TKIP+AES.

Par contre cela fonctionne avec le module iwl4965.

Comme je navigue entre les réseaux de l'université et la maison, le choix est donc de désactiver ndiswrapper au démarrage, puis suivant l'endroit ou je me trouve, de charger le bon module via la commande modprobe.

Cette solution n'est pas très pratique, mais semble fonctionnelle.

Il ne me reste plus qu'à tester la solution de compat-wireless.

''compat-wireless'' freeze la machine

Après avoir téléchargé l'archive sur http://wireless.kernel.org/en/users/Download, la mienne datait du 05/05/2008, compilé puis installé les nouveaux pilotes, le chargement du pilote iwl4965 provoque chez moi le blocage de la machine.

J'ai donc du réinstaller les pilotes d'origine :

 apt-get install --reinstall linux-ubuntu-modules-2.6.24-16-generic

et conserver ma solution non pratique mais fonctionnelle.

Compiz fusion : exit les "3D windows"

Quelques modifications pour les plugins de compiz-fusion. Si comme moi vous upgrader d'un” Gutsy Gibbon, il faut commencer par effacer les plugins éventuellement installé pour la 7.10.

rm ~/.compiz/plugins/*

Ensuite suivre la documentation à l'adresse suivante : http://doc.ubuntu-fr.org/compiz_fusion

Les 3D windows n'existent plus, dommage.

Webcam : no way to make it work

Après un lsusb, la webcam est basée sur un chip Ali :

Bus 007 Device 003: ID 0402:5602 ALi Corp. Video Camera Controller

Après quelques recherches cette webcam demande le pilote m560x.

D'après http://www.linuxtv.org/v4lwiki/index.php/Webcams

#  m560x -- ALi M560(2/3) driver with various sensors attached
    * No properly working driver yet

Dommage…

Mise à jour au noyau 2.6.24-17-generic = toujours pb wifi

Aujourd'hui, mise à jour nécessitant un redémarrage. Passage du noyau 2.6.24-16-generic à 2.6.24-17-generic. Pas de soucis notable lors de la mise à jour.

Mais le pb wifi reste entier. Toujours pas de connexion eduroam avec le module iwl4965.

Mise à jour au noyau 2.6.24-18-generic = toujours pb wifi

Aujourd'hui, mise à jour nécessitant un redémarrage. Passage du noyau 2.6.24-17-generic à 2.6.24-18-generic. Pas de soucis notable lors de la mise à jour.

Mais le pb wifi reste entier. Toujours pas de connexion eduroam avec le module iwl4965. Cela marche avec ndiswrapper, mais les temps de connexion sont très longs.

Les 3D Windows are back

Suite à quelques mises à jour, les fenêtres 3D sont de nouveau présentes dans compiz fusion. Si comme moi vous avez essayé à partir des sources, il faut enlever les modules installés à la main, afin que la version des paquets soit prise en compte. Pour cela un simple rm du répertoire .compiz/plugins de votre home suffit et vous profitez alors des superbes fenêtres 3D.

J'ai tout de même été obligé de réinstaller Atanltis2 a la mano.

Mise à jour à 8.10 Intrepid Ibex

Mise à jour sans grande particularité, on notera un meilleur support du WIFI et bluetooth. La webcam ne fonctionne toujours pas.

Pas de soucis pour l'activation du bureau 3D.

Mise à jour à 9.04 Jaunty Jackalope

Mise à jour sans histoire.

Au redémarrage du bon et du moins bon :

Pour la 3D la solution utilisée pour la Gustsy à fonctionné pour moi. Activation des cartes blacklistées dans /usr/bin/compiz.

il faut commenter des lignes dans la blacklist de compiz (celle des chips 965)

# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T="   1002:5954 1002:5854 1002:5955" # ati rs480
T="$T 1002:4153" # ATI Rv350
#T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12"  # intel 965
#T="$T 8086:2972" # i965 (x3000)
T="$T 1002:3152 1002:3150 1002:5462 1002:5653 " # ati X300 X600,X600 X700
BLACKLIST_PCIIDS="$T"
unset T

Avoir du 1280x800 en console

trouvé sur http://forum.ubuntu-fr.org/viewtopic.php?id=243246

  Mode 0x0360: 1280x800 (+1280), 8 bits
  Mode 0x0361: 1280x800 (+2560), 16 bits
  Mode 0x0362: 1280x800 (+5120), 24 bits

Il suffit de rajouter vga=0x0362 à la fin de la ligne kernel de votre menu.lst dans /boot/grub

Le splash de démarrage est un peu décalé, mais quelle plaisir une console en 1280×800 ;-).

Mise à jour à Karmic Koala

La mise à jour s'est déroulée sans problème particulier. La webcam est toujours activée au démarrage. L'applet Network manager semble avoir été bien amélioré, et semble bien plus précis dans la détection des réseaux et leur évaluation.

Seul bémol, j'arrive pas à configurer l'écran de connexion ;), ah voila c'est là http://royto.free.fr/wordpress/index.php/2009/10/31/configurer-le-gdm-de-karmic/.

Que du bon donc…

Mise à jour à Lucid Lynx 10.04 LTS

Pas de soucis particulier à part le lecteur de cartes SD qui ne semble pas fonctionner. Sinon pour le reste, c'est sans soucis.

Install 11.04

http://theindexer.wordpress.com/2011/04/03/to-do-list-after-installing-ubuntu-11-04-aka-natty-narwhal/

http://www.ubuntuupdates.org/ppas/8

http://www.omgubuntu.co.uk/2011/01/the-omg-guide-to-must-have-indicator-applets/

http://www.liberiangeek.net/2011/03/install-google-earth-ubuntu-11-04-natty-narwhal/

http://doc.ubuntu-fr.org/tutoriel/comment_recuperer_ses_emails_entre_client_de_messagerie

http://petarstrinic.com/vcf-to-csv-converter/

http://doc.ubuntu-fr.org/indicator-applications

http://doc.ubuntu-fr.org/unity

http://doc.ubuntu-fr.org/gnome-shell

http://www.tux-planet.fr/ubuntu-toutes-les-astuces-pour-unity/

http://www.webdevonlinux.fr/2011/04/ubuntu-11-04-retrouver-vos-applications-dans-la-barre-de-notification/

http://www.lefoudupc.fr/evolution-vers-thunderbird

http://www.tux-planet.fr/ubuntu-toutes-les-astuces-pour-unity/

http://www.tux-planet.fr/unity-shortcuts-wallpaper/

Configuration du pavé num externe

http://www.think-underground.com/post/2006/11/16/359-configurer-un-pave-numerique-externe-sur-un-portable-avec-kubuntu

http://forum.ubuntu-fr.org/viewtopic.php?id=9666

synchro htc

root@coruscant:~# dpkg -l | grep opensync
ii  libopensync1exp7                      0.39-4build1                               Synchronisation framework for email/pdas/and more
ii  opensync-format-vformat               0.39-1                                     Opensync vformat plugin
ii  opensync-format-xmlformat             0.39-1                                     Opensync xmlformat plugin
ii  opensync-plugin-evolution             0.39-1build1                               Evolution plugin for opensync
ii  opensync-plugin-file                  0.39-1                                     Opensync file plugin
ii  opensync-plugin-syncml                0.39-1                                     Opensync SyncML plugin
root@coruscant:~# dpkg -l | grep format-
ii  libhtml-format-perl                   2.04-2                                     format HTML syntax trees into text, PostScript or RTF
ii  opensync-format-vformat               0.39-1                                     Opensync vformat plugin
ii  opensync-format-xmlformat             0.39-1                                     Opensync xmlformat plugin
root@coruscant:~# dpkg -l | grep libopensync
ii  libopensync1exp7                      0.39-4build1                               Synchronisation framework for email/pdas/and more
root@coruscant:~# dpkg -l | grep osync
ii  osynctool                             0.39-1                                     Commandline interface for OpenSync
root@coruscant:~#dpkg -l | grep synce
ii  libsynce0                             0.15.1-0ubuntu0~ppa1~natty1                Helper library for SynCE, a tool to sync Windows Mobile devices
ii  synce-gvfs                            0.4-0ubuntu0~ppa1~natty1                   GIO/GVFS backend for synCE
ii  synce-hal                             0.15-1                                     Daemon to maintain a connection to Windows Mobile devices via hal
ii  synce-sync-engine                     0.15-2                                     Synchronization engine for Windows Mobile devices
ii  synce-trayicon                        0.15.1-0ubuntu0~ppa1~natty1                GNOME system tray application for SynCE
root@coruscant:~#

https://launchpad.net/~synce/+archive/ppa/+index?field.series_filter=natty http://www.synce.org/moin/SynceInstallation/Ubuntu/ModernDevice https://launchpad.net/~opensync/+archive/opensync-0.22/+packages https://launchpad.net/ubuntu/natty/amd64/opensync-plugin-synce/0.15-2 http://www.opensync.org/download/releases/0.39/

Problème wifi

source : http://forum.ubuntu-fr.org/viewtopic.php?id=475741

Avec cette nouvelle version, la bouton n'active pas la carte wifi. Le bluetooth est bien activé, mais le wifi non.

la commande

sudo rfkill list

montre que la carte wifi est bloquée.

on peut la débloquer et activer la carte wifi avec les commandes :

rfkill unblock all
sudo ifconfig wlan0 up

Cependant le network-manager ne prend pas en compte les modifications et ne voit pas les réseaux. Cependant la commande

sudo iwlist wlan0 scanning

vous confirmera que la carte wifi fonctionne.

Tout est la faute au module acer_wmi qui gère les boutons des portables pour rfkill. Il bloque tout et n'est pas fonctionnel avec notre Lenovo. Il faut le blacklister. Dans un prmeier temps, un simple

sudo rmmod acer_wmi

va rendre la vie à votre carte wifi et à la gestion via network-manager. Il est maintenant possible de se connecter au réseau sans fil. Pour rendre cela opérationnel après redémarrage il suffit d'ajouter la ligne suivante au fichier /etc/modprobe.d/blacklist.conf :

blacklist acer_wmi

Puis redémarrer. Maintenant le wifi est directement fonctionnel avec le bouton on/off sur le coté du lenovo.

Problème Skype

source : http://doc.ubuntu-fr.org/skype

La webcam est fonctionnel, on peut vérifier avec cheese.

Par contre pas d'image sous skype. L'astuce consiste à lancer skype avec le petit script suivant (/home/login/skype.sh) :

#!/bin/bash
export XLIB_SKIP_ARGB_VISUALS=1 && LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

si vous utilisez Ubuntu 64 bits, remplacez /lib/ par /lib32/


Yann

public/informatique/linux/lenovo3000v200.txt · Dernière modification: 2011/06/08 15:06 par yann
CC Attribution-Noncommercial-Share Alike 3.0 Unported
www.chimeric.de Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0